Network Incident - Support Phones and Email affected
Incident Report for Panthur Hosting
Resolved
This incident has been resolved.
Posted Nov 21, 2020 - 01:58 AEDT
Investigating
We have detected a network issue affecting our servers and our support capabilities. Our network engineers are currently investigating the issue.
Posted Nov 20, 2020 - 22:48 AEDT