Service Alert: Panthur Phone Lines Currently Down

Incident Report for Panthur Hosting

Resolved

Panthur phone issues are resolved now
Posted Jun 11, 2024 - 15:19 AEST

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2024 - 12:55 AEST

Identified

We are currently experiencing issues with our phonelines. We are working on resolving this as soon as possible. In the meantime please call us on
02 8823 1023.
Posted Jun 11, 2024 - 12:45 AEST
This incident affected: Economy & Business Web Hosting, Reseller Hosting, and Stealth Web Hosting.