Website Interruption - panthur.com.au
Incident Report for Panthur Hosting
Resolved
This incident has been resolved.
Posted 3 months ago. May 29, 2019 - 14:55 AEST
Identified
Be advised our monitoring has indicated that there is currently an issue accessing our primary company website (www.panthur.com.au).

If you are trying to access the Members Area (our billing, contact and security PIN management system) you can head to https://members.panthur.com.au/

We are working to resolve this with top priority and will provide an update in 60 minutes, or if there is a significant change in the situation.
Posted 3 months ago. May 29, 2019 - 14:20 AEST
This incident affected: Panthur Website.