Panthur Economy & Business Web Hosting Disruption
Incident Report for Panthur Hosting
Resolved
This issue is now resolved.
Posted 9 days ago. Mar 12, 2019 - 07:45 AEDT
Investigating
We are currently investigating issues on some of the Panthur Economy & Business Web Hosting Servers, the issue in question may have caused disruption to website up-time, apologies for any inconvenience caused and updates will be posted soon.
Posted 9 days ago. Mar 12, 2019 - 06:22 AEDT
This incident affected: Economy & Business Web Hosting.