Phone-Support Temporarily Unavailable
Incident Report for Panthur Hosting
Resolved
This incident has been resolved.
Posted 2 months ago. Nov 22, 2018 - 16:21 AEDT
Investigating
Due to a fire evacuation, our phone support is currently unavailable.

Please login to the Members Area to submit a support request.

https://members.panthur.com.au/
Posted 2 months ago. Nov 22, 2018 - 16:01 AEDT
This incident affected: Technical Support (Phone).