Errors with domain registration, renewals and name-server changes
Incident Report for Panthur Hosting
Resolved
This incident has been resolved.
Posted Nov 23, 2021 - 08:26 AEDT
Identified
Please be aware our domain-name registrar is currently experiencing issues with their domain-management platform. This means that domain registrations, transfers and renewals may not be immediately processed. All orders placed will be processed as soon as our registrar is able.

Additionally, name-server and WHOIS updates will not be possible at this time, and will need to be performed after the issues are resolved with the domain-management platform.

We are monitoring the situation and will provide an update to this page if there is a significant change to the situation.
Posted Nov 22, 2021 - 08:21 AEDT