Email Delivery Delays
Incident Report for Panthur Hosting
Resolved
This incident has been resolved.
Posted Oct 28, 2019 - 12:06 AEDT
Identified
We are currently experiencing some delays in email delivery. Our systems administrators are investigating this with urgency.
Posted Oct 28, 2019 - 10:39 AEDT
This incident affected: Email Filtering Cluster.